Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-07-2003, 10:18 AM
Posts: n/a
Question Cruise Control problems 300 CE 24v 1992

My cruise control does not function, when you push control arm to accelerate the car accelerates holds speed for a second then starts to decelerate, I have noticed that my speedo is not always steady and occasionally shakes. Any tips please
Reply With Quote
Old 10-07-2003, 10:36 AM
ebennz's Avatar
Join Date: Nov 2000
Location: Hurricane, West Virginia
Posts: 878

use the 'search' feature.

it sounds like your cruise control amplifier is dying-not uncommon.

i got mine from caliber motors 1.800.252.6877 tom hansen.

these are ALSO available from partsshop here at this site.

WELCOME to one of the most addicting sites around!!!

*92 400e 124.034, SOLD

*92 300e 124.030, SOLD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page