Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2003, 11:37 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Does the coolant sensor affect idle and hesitation???

Hello Board.

There are 3 temp sensors on my m103 engine.

1 controls the aux fan

1 shows the coolant temp

the other sensor I am unsure of (I think EZL, CIS-E).


The problem is that my car will randomly hesitate. I can drive for 30 minutes and then my car will randomly hesitate when I pull from a light. This lasts for a brief second, but it is very noticeable. It is very bad with my A/C on, I had to unplug my 02 sensor to tone down the ferocious hesitation. I read somewhere that that third sensor(I think EZL, CIS-E) can cause these symptoms. Is this true???
__________________
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS
http://memimage.cardomain.net/member.../352975_67.jpg
http://memimage.cardomain.net/member.../748335_24.jpg
Reply With Quote
  #2  
Old 10-16-2003, 11:02 PM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
bump
__________________
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS
http://memimage.cardomain.net/member.../352975_67.jpg
http://memimage.cardomain.net/member.../748335_24.jpg
Reply With Quote
  #3  
Old 10-17-2003, 01:10 AM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Serious hesitation is usually an indication of lean running. Yes, the temp sensor could have an effect, but what cured the TE from the "I have it almost floored and it's only just above idle for a second or so" was fixing all the vac leaks. Mixture was then running at 78% duty cycle, everything is fine now that I've got it set correctly.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
  #4  
Old 10-17-2003, 02:45 AM
daveCT's Avatar
Registered User
 
Join Date: Jun 2002
Posts: 455
yup if the CIS coolent sensor is broken it will send a bad reading to the EHA and will be a noticable hesitation , 40 dallor part fastlane with a 22mm long socket i think, and 5 min to replace.
Reply With Quote
  #5  
Old 10-30-2003, 01:42 AM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Hell Board,

I bought a new CIS temp sensor today, installed it and my car still idles rough when the temp passes 85 C. Looks like my old temp sensor was working perfectly fine.

Anyone have a clue why my car does this? My car needs new stem seals, could worn stem seals lead to rough idle?





Anyone interested in buying my old temp sensor for a really cheap price? PM me if interested.
__________________
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS
http://memimage.cardomain.net/member.../352975_67.jpg
http://memimage.cardomain.net/member.../748335_24.jpg
Reply With Quote
  #6  
Old 10-30-2003, 02:24 AM
Registered User
 
Join Date: Sep 2002
Location: Denmark
Posts: 412
No i wouldn't think bad stem seals could cause rough idling. And if they did, oil-smoke from the exhaust would be VERY obvious.

I replaced the coolant temp sensor in mine last year. -Got rid of rough idling and rough running.
-Later i had to replace the entire injection system, but that's another story..

Freestyler
__________________
Never criticize someone until you've walked a mile in his shoes. That way, when you do, you're a mile away -and you have his shoes!


'86 300E optically converted to '95 E300 (Sold)
-Blauschwarz on silver
-Black leather
-17" AMG & 15" AMG for winter
Reply With Quote
  #7  
Old 10-30-2003, 04:17 AM
mike690003's Avatar
Registered User
 
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Looks like its time to take that sucker to the dealer(Gulp!).

I've spent a lot of $$$$ to try and solve this problem, and it still hesitates and misses.

I'm guessing it must me electrical
__________________
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS
http://memimage.cardomain.net/member.../352975_67.jpg
http://memimage.cardomain.net/member.../748335_24.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page