Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-13-2003, 02:01 AM
Registered User
Join Date: Oct 2003
Location: New Hampshire
Posts: 9
560SEL Blower problem

The blower in my 88 560 SEL will not work. I have checked the climate control push button panel, the blower motor and the under dash resistor (looks like a honeycomb). The blower still will not work. The fuse is also fine. Is there an under the hood resistor or something else I am missing. When I push the button to activate the blower I do hear a "click" behind the push button panel but do not know what it is. Winter is coming and I need to have a functional blower. Please help if possible.
Reply With Quote
Old 10-13-2003, 12:11 PM
Registered User
Join Date: Jul 2002
Posts: 197

Have you checked the blower motor? When I bought my 90 420sel, they had had problems with the blower motor and when I got home the next day, it quit. In checking it, the connection where the blower motor ties in had come undone. When I connected it back, it blew and has blown ever since. There is a way to bypass the resistor(porcupine) and check to see if it is the problem. On my wife's 89 300se, the blower blew, but not very hard. A checked the voltage and it appeared to be within specs, but when he bypassed the "porcupine", it blew like crazy. I replaced it and now it blows extremely hard. I don't know if this will help any, but it is some food for thought.

Reply With Quote
Old 10-13-2003, 06:56 PM
Registered User
Join Date: Nov 2001
Location: North Central Kentucky
Posts: 1,061
try this: with the pushbutton unit set to max fan, turn the ignition key slightly back from the "on" position, not enough to stop the engine, just a bit. See if the fan starts. The ignition switches go bad on these cars and that is one of the first problems you will see. My '87 560SEL needs it replaced right now and the part is sitting on the shelf in my shop waiting for me. Had to do same thing on my 123 300D. Same problem. Switch is not terribly expensive. Biggest problem can be taking apart the whole ignition lock to replace the switch, but I have to fix some dash light bulbs anyway..... I pull the whole dash cluster when I work on the switch.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page