Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-15-2003, 10:21 PM
Registered User
Join Date: Mar 2003
Location: New Hampshire
Posts: 158
Please Help I have a big problem here!!

After fighting for hours to remove the slide pins which hold my upper chain guide in, i finally got them out last night and replaced the upper chain guide, then i replaced the chain tensioner. So everything was ok. Now tonight i hear a noise from the timing cover, so I pulled it, and what do I find?

The plastic support rail which goes on top of the metal timing chain tensioner blade, is in 3 pieces sitting up between the chain and the head. So I pulled the first 2 pieces out now i have to go relieve the tensioner and get the 3rd larger one out.

My question is, is it ok to run the engine without that plastic piece on? And secondly is there anyway possible to replace that plastic piece without pulling the timing cover?

Please help, this is my daily driver!

Reply With Quote
Old 10-16-2003, 12:36 AM
Registered User
Join Date: Mar 2003
Location: New Hampshire
Posts: 158
sorry, forgot to mention car is 88 190e 2.3 8v with 91 engine.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page