Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-16-2003, 10:06 PM
Registered User
Join Date: Oct 2003
Posts: 17
windows on w140 coupes

Has anyone had this problem? They did tint on my car. But after they finished there's a slight problem. Maybe it's because of water that got in. Maybe it's because there's a problem with my passenger door, it can't be locked, but the dealer is going to fix it next week.

Anyway, I open the passenger door, the window goes down half an inch as usual, but instead of staying there, it goes all the way up again in one second!!! So when I try to shut the door, the window goes against the insulation, and that's no good. I have to simulate it, by holding the doorhandle opened and shutting the door at the same time, then the window goes up and seals right.

Any ideas? I'm hoping when it dries it won't do that. Or maybe it's just a glitch.
Reply With Quote
Old 10-16-2003, 10:30 PM
Registered User
Join Date: Oct 2002
Posts: 188
I have a W140 not a C140 so can't help much. HOWEVER, I have seen this problem somewhere on this board and its also to do with tinting.

If I remeber correctly, it was because the tech who tint your windows unplug the battery when they did the job so that the entire window stick out for them to do the job. If they keep the battery connected they cannot do the job with the window moved slightly down.

Anyway, to fix, have you try re-programming your windows? If you don't know how, look for it here. Again I think the procedures is something like open the window to FULL open than press and hold the switch for 5 seconds. After that, close the window to FULL close and press and hold the switch for 5 seconds. This should be a fix.

Reply With Quote
Old 10-17-2003, 11:17 AM
JimF's Avatar
'94 S500: only 793 sold!
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,924
There is a procedure . . .

in your owners manual to 're-sync' the windows. But your problem sounds different for the 'standard' problems.

Also do a search and you'll find a number of threads.
Regards . . . . JimF
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
Old 10-18-2003, 07:53 PM
Registered User
Join Date: Oct 2003
Posts: 17
just tried it again, and it looks like the passenger windows are working now. I open the door and the window goes down an inch and stays. I guess that was just a glitch since the water got in during the tinting job. PHEW!

The door doesn't work still, can't lock it. but dealer is fixing that.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page