Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-17-2003, 12:58 AM
Registered User
Join Date: Oct 2003
Location: Blackhawk, CA
Posts: 8
Unhappy CCU problem on W126?


Well, the climate control system on my '87 560SEL is acting weird.

First, it was blowing hot air in defrost mode after I start the car, and wouldn't budge no matter what position was selected on the Climate Control unit (including off). Gilly suggested (Thanks Gilly!) that the fuse might be at fault since the system's designed to default to full hot defrost mode in case of system failure to keep the glass clear.

So I swapped the #5 fuse with a spare, and it *seemed* to work fine for a while. But then I noticed something else that's peculiar: None of the CCU controls work. Off doesn't turn the system off, nor can I redirect the air--they seem to always be coming out of the center dash vents. The temp control wheel is doing its thing, since it responds appropriately to hot/cold air requirements and generally keeps the interior comfortable. But I'm a little worried about not being able to use the defrost function, nor to turn the system off should that be necessary.

I brought it to a local shop (good shop--i take my Bimmer there), and they suspected that the CCU is shorted out (since it's not responsive) and wants to change it out. But at $350 for refurbished unit and close to $500 for a new one, I'm hoping that there's another possibility out there that should be investigated before we swap out the CCU??? I'd just hate to do a bunch of trial and errors and run up a huge bill (which it sounds like it's going to be!). Would vacuum leak do this?

TIA for your help!
'87 560 SEL
'97 BMW 540i 6speed
'00 Lexus LX470
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page