Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-17-2003, 11:31 PM
Registered User
Join Date: Apr 2002
Location: Calgary, Canada
Posts: 164
Question W140 M104 engine cover

During a road trip today, I was heading into 130 km/hr winds (at 100 km/hr), and the engine cover underneath the front of the engine broke off. Looks like the bolts at the front of the cover were missing and it caught the wind and whoosh.... It's pretty busted up.

Is this cover just for looks, or is there a more important function? I'm wondering whether I need to/should replace it.


1995 S320
Reply With Quote
Old 10-18-2003, 12:58 AM
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,503
I could be wrong, but I believe it is part of your car's "aerodynamic system", in that it reduces drag, and reduces uplift at high speeds.
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:02 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page