Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-18-2003, 06:55 PM
Registered User
 
Join Date: Oct 2003
Location: SHEFFIELD ,ENGLAND
Posts: 1
380sel Running Hot

I AM HAVING A PROBLEM WITH MY 380SEL WHICH IS RUNNING HOT AT AROUND 100 DEGREES. THE WATER PUMP HAS BEEN RENEWED , AS HAS THE THERMOSTAT. THE VISCOUS FAN HAS BEEN RENEWED AND ALSO THE WATER RESOVOIR CAP HAS BEEN RENEWED ALL TO NO AVAIL. THE CAR IS NOT LOSING WATER AND IS OTHERWISE RUNNING EXTREMELY WELL . THERE ARE NO SIGNS THAT THERE ARE ANY PROBLEMS WITH THE HEAD GASKET , NO WATER LOSS OR OIL LOSS AND NOSIGN OF THE TWO MIXING ANYWHERE . I RAN WATER THROUGH THE RADIATOR FROM THE TOP END WITHOUT IT BEING REMOVED AND WATER RAN THROUGH AND OUT OF THE BOTTOM SEEMINGLY OK. SO IM A LITTLE STUCK REALLY DOES ANY ONE HAVE ANY IDEAS
P.S THE CAR IS A 1982 MODEL AND HAS COVERED 115.000 MLS FROM NEW.
THE ONLY THING THAT SEEMS TO KEEP THE TEMP NEAR TO NORMAL IS BY TURNING ON THE HEATER CONTROL IN THE CAR .
AT THE OTHEREND OF THE SCALE THE TEMP DOES NOT RISE ANY HIGHER THAN 100 DEGREES
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page