Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-21-2003, 01:02 PM
Registered User
 
Join Date: Apr 2003
Posts: 345
'86 190D auto tranny slips/flares 3-4 gear

This tranny has been losing fluid for the past couple of months, a mystery since there is no huge leak underneath. But it has steadily increased tranny fluid use until now it takes 1 quart a week to top it up. When it has proper fluid level it runs great, pulls hills fine (as much as a 2.5l non-turbo diesel can)

Last evening it shifted 1-2, 2-3 and then at about 45 mph the tach zoomed to 5000 rpm and it felt like it had no power beyond that, if you come to a stop and try again it does the same, pulls great until 45 mph then its like it hit a wall and slips and flares and reads 5000 rpm on the tach.
whats going on ? Is it the torque converter or the tranny itself ?
Reply With Quote
  #2  
Old 10-21-2003, 10:05 PM
Registered User
 
Join Date: Apr 2003
Posts: 345
Please, anyone ///
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page