Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-21-2003, 04:38 PM
Registered User
Join Date: Apr 1999
Posts: 2,632
Question W124 300TE A/C Blower fan is not working when the car is running

Our 1988 W124 300TE A/C Blower fan is not-working when the car is running. If I turn-off the engine and put the ignition switch in position 2 WITHOUT starting the car, the blower fan works in HIGH, AUTO, and LOW, but once started the blower fan does *not* work.

All fuses checked OK and replaced 2-years ago. What get's me is it works when the engine is not running . . .

Any ideas?

:-) neil
1988 360TE AMG
1993 500E
Reply With Quote
Old 10-21-2003, 05:25 PM
Registered User
Join Date: Jun 2000
Location: Plano, TX
Posts: 2,476
If I were a bettin' man, I'd bet on the ignition switch. Seriously, try jiggling/wiggling/otherwise adjusting the ignition after starting the car, see if the fan starts. Otherwise, try to determine whether the PBU has power after starting the car. One way would be to check the monovalve. It should be supplied with 12v whenever the PBU is placed in the 'off' mode.

Happy troubleshooting,

- Jim
Reply With Quote
Old 10-21-2003, 09:07 PM
Registered User
Join Date: Apr 1999
Posts: 2,632
Yep, it's the ignition switch. I've checked the W124 Service CD-ROM, and I can't find the procedure to replace the ignition switch.

I did find 46-8010, "Removal and Installation of Steering Lock- Complete". It seems excessive. . .

Anyone done this before and can explain generally the procedure?

:-) neil
1988 360TE AMG
1993 500E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page