Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-22-2003, 09:34 PM
Registered User
Join Date: Jun 2002
Posts: 57
ABS light: abs has a mind of its own

I recently changed the front rotors on my '89 420 SEL. I followed Thomaspin's instructions regarding the steps and procedures and everything went well.
However, after driving the car, the brakes worked fine but the ABS light has come on periodically. There hasn't been a pattern that I have been able to notice as to why the light would come on.
When the light doesn't come on, the ABS begins working when you break at lower speeds. I pulled the wheels off and checked the speed sensors (made sure that they were clean and free of debree) and have still had the same problem.
Any thoughts would be appreciated.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page