Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-28-2003, 06:32 PM
goodworkmax's Avatar
Registered User
Join Date: Oct 2003
Posts: 1
hard start and rough warm up on '72 280 se

I have a '72 280se 2.8 which is having trouble with the warm up period but otherwise runs great. Once it gets started it won't take any throttle for the first 10 seconds or so and for the first minute is sounds as if it's running on 3 or four cylinders. than you can hear it start to clear up... 5 cylinders and then finally six. Once it's warm, it runs strong and smooth with only an occassional "pop" at low throttle cruzing at say 25-30 mph. Do you think it could be a leaky injector? Help?

I just had the valves adjusted, new points, new rotor/cap and new bosch Super plugs.

Have had:
240 d
'81 300 cd
volvo 850
volvo v70
volvo 240dl
saab 900 turbo
two fiat 124 spiders
two porsche 914s 1.7 & 1.8
'92 Isuzu Trooper
Audi GT coupe
'95 BMW 325i convert.
'71 BMW 3.0CS (grey mkt)
Peugeot 505 wgn
Toyota corolla hatch
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page