Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-01-2003, 05:54 PM
Registered User
 
Join Date: May 2003
Location: Long Island,N.Y
Posts: 7
92' 400e climate control

my climate control is not working. I took the unit out and tried to remove front panel but it was hung up on the buttons. how do you remove the buttons? 3 clips on the temp knob were loosened and then I moved the knob. When I returned the unit to the car it worked until I moved the temp knob again?
__________________
JOE
2001 E55
1992 400E
1976 Triumph TR-6
Reply With Quote
  #2  
Old 11-01-2003, 10:17 PM
zeronero's Avatar
Registered User
 
Join Date: May 2003
Location: San Francisco Bay Area
Posts: 426
The black part of the buttons, the ones you touch simply clip on a plastic button behind it. I used a screw driver to get them of, some of the black parts did break where they clip on to the plastic behind it.
__________________
1992 Mercedes-Benz 400E
2002 Mercedes-Benz ML500
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page