Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2003, 08:23 PM
Registered User
 
Join Date: Jul 2000
Posts: 6
Question 1985 190E Heater/AC fan

Climate control system is working as I can feel a small amount of warm or cold air (depending on temp setting) coming through the vents. The fan does not blow at increased speeds when using the manual fan speed switch on the dash. Is the switch bad or is the fan motor out? If the motor is bad, how do I change it? It is getting cold here in the northwest, so any help would be much appreciated.

Thanks very much, Joe
Reply With Quote
  #2  
Old 11-04-2003, 02:04 AM
Registered User
 
Join Date: Nov 2001
Location: North Central Kentucky
Posts: 1,065
Try this: While the car is running but parked, push the button for max fan. Now turn the ignition key ever so slightly to one side then the other. Don't turn off the car, but move the keyswith off of the detent just a hair. See if the fan doesn't start. Common problem for the switch to go flakey. Not very expensive, but a bit of a pain to replace.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page