Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-28-1999, 09:54 PM
126MAN
Guest
 
Posts: n/a
Hello, I own a 560 SEL and I have a knock from the top end of the motor. Is the car safe to run ? What are all the possible causes for this because I would like to know if it is a job I can handle. I just had an oil change two days before I started hearing the knock.
Reply With Quote
  #2  
Old 12-28-1999, 10:00 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You are most likely hearing a timing chain that is about to be a 5,000 dollar problem if you drive. If you get it fixed now, it could be a 1,000 problem. If the timing chain and rails are bad, have the whole set done. (chain sprockets, rails, tensioner and all factory parts!!!)

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 12-28-1999, 10:30 PM
126MAN
Guest
 
Posts: n/a
The chain was checked by the dealer only a few weeks ago so I am wondering could it be a lifter problem ?
Reply With Quote
  #4  
Old 01-10-2000, 09:23 PM
Stevegman
Guest
 
Posts: n/a
My 85 500SL has a mild knock that sounds like it's coming from the valve closest to the driver. It's not very loud but of course I am concerned. I saw a post about damage to a cam if there is a rocker problem, but if a valve compensator is worn (cupped) or something, is this a problem to drive? Please advise and thanks for the great site.

Steve

85 500SL Euro
Reply With Quote
  #5  
Old 01-10-2000, 09:58 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have seen many rockers and cams worn, but I would call this a tapping noise, not a knock.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #6  
Old 06-16-2000, 03:35 PM
Stevegman
Guest
 
Posts: n/a
Yep, it's a tap, not a knock. I just had a timing chain replaced and the cams are fine. Rockers okay but replaced as well. Still tapping and the shop said it's a lifter and when I get a chance, I'll leave it with him to find out which one and replace it. Anyone know how to determine which one is bad?

Steve
85 SL500
Reply With Quote
  #7  
Old 06-17-2000, 12:17 AM
Alain V.'s Avatar
Senior Member
 
Join Date: Aug 1999
Location: KS.
Posts: 459
Depending on the miles your car has,,,,,if the noise is a lifter, you would probably be better off replacing all of them at once.

They all have been in there for the same miles and if one is failing, others may soon follow. If you do them all at once, you can forget about them. If you do just the one or two that are bad now, you will always be wondering,,,,,when the next ones will start to tick.

------------------
Reply With Quote
  #8  
Old 06-17-2000, 12:41 AM
Registered User
 
Join Date: Nov 1999
Location: Lynnwood, WA, USA
Posts: 178
My 500SEL was making loud tapping noises. It turned out to be two loose lifters. After the lifters were retorqued, all noises disappeared. The tapping started after I have switched to Mobil 1. I wonder if the lower viscosity somehow loosened the bolts.

[This message has been edited by TommyMB (edited 06-16-2000).]
Reply With Quote
  #9  
Old 06-17-2000, 08:55 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Boy, that Mobil 1. That is some kick ass oil. I wonder if I can get it to change my plugs...

------------------
Jeff Lawrence
1987 300e
1989 300e
1987 BMW 325
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
107SL top folding technique-- Large pictures dmorrison SL Forum 23 07-30-2009 11:31 AM
Convertible top question on 129 SL's BobH SL Forum 0 09-15-2003 02:43 PM
96 SL320 top light on roll bar lite on -top not working adainc SL Forum 2 06-16-2003 12:09 PM
Rear end low & front end high. Advise needed mikaelw2001 Tech Help 1 02-12-2003 05:37 PM
Top problems with SL600 96 Syavik Tech Help 2 04-02-2002 05:44 PM



All times are GMT -4. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page