Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-17-2003, 06:32 PM
Posts: n/a
Unhappy missing menu in instrument cluster setup for UK

Hi there,
I hope this is not a silly question, but I am new to mercedes & forums. I have brought a c200 kompressor classic (aug02) & tried to setup the multi function display. In the instrument cluster i have the "select display" menu missing for speed display or outside temperature. As I wanted to have the temperature displayed in the bottom left hand corner, instead of the speed in KM. I called the local garage & after a lot of waiting about, I was told this is not adjustable in the UK. Just incase I travel abroad, so I will know the speed in km's. I thought the guy was trying to be funny, but he actually ment it. Then I visited a frend who has just brought a c320 amg & the menu is availble in his car & displaying the temperature. Can anyone offer any information about getting the car reprogrammed ?, to have this missing menu put back in. Thanks in advance Tony in Sunny Clacton, Essex.
Reply With Quote
Old 11-17-2003, 09:39 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Read the owners manual

Reply With Quote
Old 11-18-2003, 03:57 PM
Posts: n/a
I did read the manual, thats how I know the menu is missing & mercedes state it is removed for the UK.

Still interested in finding someone / somewhere to have it reprogrammed & the menu put back.

Reply With Quote
Old 11-19-2003, 07:47 AM
Registered User
Join Date: Jan 2002
Location: England
Posts: 1,841
It *may* be possible, if you're really stuck (but it's not hugely likely), that in can be changed by plugging in of a diagnostic computer to the cars on board diagnostics.

Find a friendly well-equipped independant and they'll have a look for you I'm sure.
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page