Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-22-2003, 08:11 PM
Registered User
Join Date: Sep 2003
Location: Kingsburg, Ca.
Posts: 87
Rough running 450 sl

I have a 1980 450 sl which I just got about 4 months ago. I started it up today for the first time in about 3 weeks. It was idling rough, I figured it just needed to warm up a little, but it persisted even after a good drive. It's not just at idle when it's rough, but all the time. I had no problems previously, not even a hint.

Should I be looking at plugs, cap, rotor, wires, fuel filter? If so, which first. Where is the fuel filter located on these?

Oh yeah, after my drive, when I put it in the garage, I could smell a sort of burning smell that I previously didn't have. Couldn't pinpoint the smell for sure, but perhaps from the exhaust (not sure though because the smell that I smelled from the exhaust pipes may have been there before and I didn't notice it). And advice would be appreciated!

Chris Meyer
1980 450 SL (99k miles)
2003 Honda Odyssey (Family Hauler)
2006 BMW 330i (daily driver)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page