Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-24-2003, 11:35 PM
Registered User
Join Date: Apr 2001
Location: Joliet Illinois
Posts: 309
W124 Rear Subframe Mount Question

I'm replacing the forward rubber mounts on the rear subframe of my '92 300e and after removing the bolts from the mount, there does not appear to be enough clearance above the subframe for the new mounts in. What else to I need to loosen to get the subframe to drop another inch or so?

I'm thinking that either the shock absorber or rear subframe bushing are holding it up. I'm a little hesitant to try to remove the bolt from the rear bushing because if it is like the fronts, the bolt was seized to the sleeve in the bushing and the rubber tore when I turned it.

I already removed the safety strap under the driveshaft, the exhaust, the trunk drain hose.

Any help from someone with experience doing this will be appreciated.

Reply With Quote
Old 11-27-2003, 12:09 AM
Registered User
Join Date: Aug 2003
Location: Orlando
Posts: 79
try this excellent link that Cornblat directed me to.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:50 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page