Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-27-2003, 06:31 PM
Registered User
Join Date: Jan 2003
Location: Chehalis , Wa
Posts: 14
Question Heater Mono Valve clicks...

I Recently purchased, a 1981 Euro 280SE 6 cyl, manual trans, Whata fun car....The mono valve Which actually seems to have two solenoid bodies..makes a soft clicking noise about once
every 4 seconds whenever the engine is running or the
key just in the ignition on position, BUT only after the engine is up to operating temp...Heater seems to function OK... Anyone familiar with this....

Thanks in advance....

Ron C.
'81 280SE
'70 280SE
Reply With Quote
Old 11-27-2003, 11:41 PM
pberku's Avatar
Registered User
Join Date: Oct 2003
Location: Montreal, Canada
Posts: 737
This is a normal function of your climate control system when its trying to maintain your pre-set cabin temperature.

When the system calls for heat, it will cycle the MonoValve ON and OFF every few seconds.

There is nothing wrong. All is well.


Last edited by pberku; 11-28-2003 at 01:08 AM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page