Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-28-2003, 10:55 AM
Registered User
Join Date: Jan 2000
Location: PA
Posts: 5,440
WW Delay Stopped Working

After driving 1000+ miles in 2 days in constant rain, the windshield wiper delay does not work. Even though the ww switch is in the delay position, the wipers continue to run as if the switch was in the low speed position.

If I turn the ww off and immediately on, there will be a 5 second delay as there should be, but once they start wiping they keep going with no delay between wipes. High and low speed work OK, delay is the only problem. Pushing the turn signal stalk in to the spray position causes the wipers to work for 2 or 3 times which is what it is supposed to do.

Where is the device located that causes the delay? Maybe I can just replace that from a parts car.

Car is a '80 300SD with 250,000+ miles. I originally put this post in the Diesel section but I had no useable answers. Please reply if you can help.

Reply With Quote
Old 11-28-2003, 02:56 PM
Registered User
Join Date: Sep 2002
Location: Allentown, PA
Posts: 480
All my wiper functions were ok except for the intermittant, that had a mind of its own (2 wipes, 8 wipes, no wipes).

I cured my 94 E320 with a wiper relay (in fuse box) for $68 from FastLane.

You might get lucky by just cleaning the relay's contacts and or the receptacle in the fuse box (dirt and/or water).

Reply With Quote
Old 11-28-2003, 11:44 PM
Registered User
Join Date: Jan 2000
Location: PA
Posts: 5,440

OK, I'll try looking for the WW relay in the fuse box and see if I can fix it. Thanks for the reply.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page