Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-06-2000, 12:37 AM
Alday
Guest
 
Posts: n/a
My 1983 300D has developed a slip when starting out, similar to a slipping clutch in a manual transmission. It acts as if a band or clutch is about shot. The slipping appears once the car warms up (doesn't slip cold), and only appears to affect the start-out. As I understand it, the tranny was replaced with a rebuilt one about 30,000 miles ago, and seems rock solid otherwise (sometimes TOO rock solid). I replaced the fluid & filter about 3000 miles ago (the fluid looked pretty good), and the slipping has gradually appeared and worsened since then. The local independent MB shops seem stumped, and talk of either adjusting the modulator, or replacing the tranny (aahhhh!) Any ideas? Thanks!
Reply With Quote
  #2  
Old 06-06-2000, 03:20 AM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,267
Hey Alday, yeah I had my 300d trans
'rebuilt' some years back and about
25K later it began to slip when hot.
Could have been the clutches or particles clogging the filter or something else. I had Peter Schmid transmissions replace it
1800.00 in one day. Mountain View Ca.
They do trannys for many businesses in the Bay Area. Cut out the middleman.
Call Ian at 650-390-9500
Maybe he can steer ya right. Nice guy.

Why not re-examine the filter for particles?
Cheers

------------------
1979 300D
133K miles
1989 300SE
1995 C280
Reply With Quote
  #3  
Old 06-24-2000, 01:50 PM
Alday
Guest
 
Posts: n/a
Just thought I'd post the conclusion of the story for "posterity"...
I took the car into a local tranny shop, and the bottom line was rebuild time. They agreed that MB parts were the only way to go, and mentioned that the last rebuild probably DIDN'T. Maybe why the tranny only lasted around 40,000 miles? He said that they usually only see around 50,000 miles out of rebuilds without MB parts. ANYWAY, they wanted over $2300 for the rebuild (1 year/12,000 mile warranty). After taking the car home to think about it, I found that they WAY over filled the tranny. So much for THEM!
I ended up taking the car to an independent MB shop in Camarillo. The rebuild was out of a specialty rebuild shop (MB only) in LA, dyno tested, with a 30 month, unlimited milage warranty. Installed, with a few other "odds & ends" (included a flush, & new VCV required for the warranty): around $2150.00.
Now you know the REST of the story... So much for the front seats getting recovered (at least THIS year)! Ouch...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opinions on purchasing a 1987 300D swogee Diesel Discussion 12 05-03-2005 11:27 AM
Very hard starting 300D Chris J. Diesel Discussion 10 11-26-2002 06:53 PM
1987 300D Turbo Glow plug light out. hard starting jfikentscher Diesel Discussion 2 11-13-2002 01:54 PM
85 300D Hard Starting drawde Diesel Discussion 7 11-04-2002 02:56 PM
300D turbo diesel has trouble starting...any advice ? SV Tech Help 3 10-30-2000 10:42 AM



All times are GMT -4. The time now is 07:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page