Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-28-2000, 10:44 AM
Registered User
Join Date: Dec 1999
Location: Glen Burnie, MD, US
Posts: 30
My 400E has undergone a major repair. The entire cooling system has been replaced by my local MB dealer to include a new condenser. My car runs hot while at traffic lights and never cools unless I am driving 75 mph. The dealer has stated that the repair was done correctly, however I am upset about the discomfort the A/C system in my car is providing in the 80 and 90 degree days in Maryland. Any suggetsions?

Brian M
92' 400E
Reply With Quote
Old 06-28-2000, 10:49 AM
Posts: n/a
i don't know about the a/c but a tempary tip for the stop lights is what my chysler leabarons mannual says when at stop lights put the car in nutral this will help the car cool down
this may not be the same with mercedes

1985 euro 500sel 220k
1981 300sd 278k sold
1989 chrysler
leabaron 130k
1990 320sl (hopefully)
Reply With Quote
Old 06-28-2000, 03:02 PM
Mike Murrell's Avatar
Registered User
Join Date: Feb 2000
Posts: 2,141
It appears you're located in Maryland. I don't know how close you are to Timonium Md.
You might try Roy Fields Auto Service in that city. Lot's of folks on this and other MB WEB sites have praised his skills. Their phone number is 410-252-4101. Roy Fields could assess your problem. With this in hand, you could then approach the dealer and have him do what he didn't to right the first time around.

Mike Murrell
'91 300-SEL
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C problem Joko Tech Help 5 08-12-2003 12:44 PM
Swapped the CCU, the problem came back - new theory, still need help with a/c diagnos bodyart27 Diesel Discussion 1 06-29-2003 04:34 PM
a/c problem became less strange jivadent Diesel Discussion 2 10-30-2002 04:19 PM
Strange a/c problem on '86 300E can-do Tech Help 4 06-07-2002 12:12 AM
A/C problem has got me hot!!! Matt201 Tech Help 1 07-31-2001 11:39 PM

All times are GMT -4. The time now is 08:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page