Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-02-2000, 11:02 AM
Posts: n/a
Yep...everyone's most dreaded problem...the intermittent electrical short. On my 89 190E 2.6 I just replaced all four of the "balloon" bulbs in the sunvisors and, the part(s) with the metal contacts that the visors snap into. Sometimes they work...and sometimes they don't! I've been told by my shop here in Tucson, Dearing (did everyone see "Gone In 60 Seconds....the shop in the movie was called "Dresden"...ha ha!) that possibly the fault my be in old/shorted wiring from the visor. Fuse is fine. Anyone with similar problems? Thanks

Dave Browning
89 190E 2.6

PS- Thanks for the "overcharging/pressure" suggestion on my last post...I'll check it out!
Reply With Quote
Old 07-02-2000, 05:40 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Dave, if you are talking about the visor retainer clips, check each with a voltmeter to see if you're getting 12 volts from each. Then, if you are, seriously clean the little slip rings on the visors. These can get dirty and give you intermittent contact. I have had this little problem twice and cleaning them did the trick. Good Luck..

Jeff Lawrence
1987 300e
1989 300e
1987 BMW 325
Reply With Quote
Old 07-02-2000, 05:58 PM
Posts: n/a
Jeff...I'll give your suggestion a try. God only knows the nightmare it would be to trace back the wiring......ugh! Thanks for the tip!

Dave Browning
89 190E 2.6
Reply With Quote
Old 07-02-2000, 08:43 PM
Registered User
Join Date: Mar 2000
Posts: 217
I have the same problem on my passenger side vanity mirror. Sometimes the light will be on....sometimes not...if its not on....i'll smack it a couple of times, and the light will come on. I think it just has a life of its own...but it doesnt bother me. Im sure it would bother a date trying to check her makeup in the middle of the night--oh well...

1989 300E (108k miles)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Mercedes Used Parts For Sale & Wanted 8 01-28-2005 09:45 PM
Should 190E stay or should 190E go? blackmercedes Open Discussion 14 02-09-2003 11:03 PM
Bass box in 190e (stop me if you've heard this one before) Dan Rotigel Car Audio and Multimedia 0 08-13-2002 11:34 AM
85 190e loping at stop lights Tlook Tech Help 1 05-11-2001 09:39 AM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Performance Paddock 3 04-22-2000 11:11 PM

All times are GMT -4. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page