Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-19-2003, 10:09 PM
Registered User
Join Date: May 2002
Location: Irving, Texas
Posts: 80
w210 weird lighting troubles

today they passenger rear window regulator tanked when trying to roll up the window, so I got the new one from the dealer, drilled out the rivets, and put the new one in.. no problem. afterwards when I use the remote to lock the doors and arm the alarm the hazards dont blink like they used to. they blink when I unlock the doors but not unlock. the rear dome light and the right rear light on the bottom of the door wont turn off either. I had to unplug them so they wont run the battery down. the rear dome I can turn off using the switch, if the car is running, but when I get out and close the doors, it stays on. This the oddest thing I have ever seen in a car. any ideas? I'm wondering if I blew a fuse or something.
Reply With Quote
Old 12-20-2003, 05:58 PM
Registered User
Join Date: May 2002
Location: Irving, Texas
Posts: 80
no ideas? anyone?
Reply With Quote
Old 12-21-2003, 12:02 PM
Southern's Avatar
Registered User
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
I would check that the door switches work properly. Each door has a switch which detects when the door is fully shut. When the door is fully shut the interior lights should start to dim off.

It's possible that you may have multiple problems but I would start with the door switches first.
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
Old 12-21-2003, 08:45 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Yeah, sounds like a door jamb switch to me too. Probably check the one for the door you replaced the regulator on first. The black switch with the spring-loaded plunger. This would cause both of your problems.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page