Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-28-2003, 11:21 AM
Registered User
Join Date: Nov 2000
Location: Gaithersburg, Md
Posts: 40
300E trans problem

My 300E doesn't go in reverse anymore (well it barely moves when I rev the engine and only if its on a slight hill). It shifts fine going forward but for some reason doesn't go in reverse. Anyone know what this could be (besides the whole tranny)
Reply With Quote
Old 12-28-2003, 12:35 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Might as well be the whole tranny as once you have pulled the reverse clutch apart to fix it you might as well do the same for the rest of that old unit and clean up the mess.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page