Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-30-2003, 08:48 AM
bluebenz1
Guest
 
Posts: n/a
help please !!!!!!!!!!! hazard lights on1994 s 320

have continual hazard light flashing, everything else works ok alarm elecrtics etc, was power washed before i bought it 3 days ago, started morning after i got it and after a night of heavy rain, has not been dry since, could this be a water short help plesase as i cant brive my newly aquired lovely s 320. very frustrating


any ideas !!!!!
Reply With Quote
  #2  
Old 12-30-2003, 09:01 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
There is a combination relay in the rear section of the fuse box that controls blinkers & hazzard warning lamps, other than a stuck switch THAT relay is the most common problem.

Should have MB number 140-820-26-26 on the outer cover.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 12-30-2003, 09:09 AM
bluebenz1
Guest
 
Posts: n/a
thanks,
will have a look now, how does one check this for good operation or is it just a case of buying a new one
Reply With Quote
  #4  
Old 12-30-2003, 09:40 AM
bluebenz1
Guest
 
Posts: n/a
am i looking for a 5 inch by one inch square (apox) black plastic box set behind the fuse box if so i have pulled both connectors, put the fuse back ( 17) and still the hazards flash very rappidly

the number on the box was 140 542 00 19

any conclusions
thanks
Reply With Quote
  #5  
Old 12-30-2003, 11:28 AM
bluebenz1
Guest
 
Posts: n/a
dont think its a stuck swith as when i opperate the hazard warning switch they flash at the normal rate(slightly slowar than thew do now) . also if i use the indicator switch they flash normaly
Reply With Quote
  #6  
Old 12-30-2003, 12:39 PM
bluebenz1
Guest
 
Posts: n/a
hope this isnt an introduction into the elecrical nightmares of a merc

does anyone have any ideas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page