Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-06-2000, 08:23 PM
Registered User
Join Date: May 1999
Location: Charlotte, NC, USA
Posts: 688
Have a friend with a 123 T/D sedan which lost all his freon due to a leaking high pressure switch. No problem, replace the switch and recharge system. All works fine for a few weeks until no cold air again.
This time the compressor is running but the blower does not. If you jiggle the key back a little in the ignition, it works. No problem, faulty switch. Replace it. But why if you remove the A/C fuse do both the compressor and blower quit, while the ignition switch only affects the blower? Is this some strange Teutonic procedure or is the compressor wired in through the back door?
Please give me some insight into this. Thanx.

Tobias MB
300SE, 300CE, C280Sport, 190/5.0
Reply With Quote
Old 07-07-2000, 07:14 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
HI, yes MB does do strange things with blower motors. The Ignition switch on most older cars did have a circuit just for blower motor & nothing else (15X). Since blowers with A/C/C use upto 30A, they deemed that necessary. On later cars like your W140 S-Class there isn't even a fuse for blower & it's not even switch off w/key! In other words circuit 30 directly from Battery! So that rest function will operate w/o key.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'84 300SD W126 - A/C clicks off dead once it reaches dialed in temp bodyart27 Diesel Discussion 7 08-12-2005 03:19 PM
Spark plug wire corrosion: What's the cause Ron in SC ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 08-14-2004 10:54 PM
'84 300SD W126 - A/C Question - the saga continues bodyart27 Diesel Discussion 13 06-23-2003 05:32 PM
is a/c and central locking system on the same vacuum system? 79 300CD Diesel Discussion 4 05-06-2003 03:04 PM
A/C Compressor Won't Engage '88 420SEL mscotta Tech Help 4 12-05-2001 10:05 AM

All times are GMT -4. The time now is 10:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page