Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-11-2000, 10:38 PM
Posts: n/a
Doen't start. When you hot wire the pump it starts and seem to run normal.
Pin 30 on fuel pump relay is hot (+) when
shorted to pin 87 the vihecle starts-can we assume the relay is defective ??
Reply With Quote
Old 07-12-2000, 07:25 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Sounds logical to me. Fuel pump relays are a common problem.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Greasecar giving me pains... '80 300D driad_98 Diesel Discussion 14 07-14-2004 03:40 PM
Mechanical Fuel Injection Pump not working properly M_Anker Vintage Mercedes 12 06-06-2004 12:40 PM
1980 380 se is what is on the title, fuel issues frankford Tech Help 0 12-03-2003 07:48 PM
What Is a Fuel Thermostat In The Fuel Injection System? ezrider Diesel Discussion 7 12-30-2002 11:57 AM
Bleeding fuel system, besides primer pump. TurboTurbine Tech Help 3 10-23-2001 07:00 AM

All times are GMT -4. The time now is 07:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page