Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2004, 11:33 AM
Registered User
 
Join Date: Jan 2004
Location: Austin, Texas
Posts: 167
another 126 ABS question, please!

On my 89 420,

I am getting an occasional ABS engagement, almost always upon first backing out of the garage and a few times thereafter, like at slow speeds coming to a stop. No ABS light whatsoever when underway and the light does work, it will light up with the ignition on, self test for the bulb if you will. I have cleaned the front sensors but maybe they are still bad??

Chas
Reply With Quote
  #2  
Old 01-12-2004, 12:31 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Definitely a sensor. We use about 4 times as many right front as left, so maybe you could roll the dice. If you pay to have it tested it will cost atleast half as much as a sensor.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 01-12-2004, 02:34 PM
Registered User
 
Join Date: Jan 2004
Location: Austin, Texas
Posts: 167
Thanks Steve,

I should have caught this earlier as I was just all into the front end doing the brakes, rotors, center link and radius strut bushings a few days ago. I do remember changing some ABS/wear indicator harnesses a few years ago on another 126 and the only drag is having to uncouple the brake lines to attach the new harness fastenings at the brake hoses, brakes will need to be bled and all.

It will be nice to get this beauty all back to snuff, I just got it a few weeks ago and the wifey thinks I have inherited a money pit. I haven't told her about the bad vacuum elements in the dash, won't need full bore a/c for a few months so I got some time on that one, thank goodness.

I knew it needed some work and have been here and done this so not too much stress on me. These are such beautiful cars!!


Chas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page