Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-30-2004, 09:37 AM
dentman
Guest
 
Posts: n/a
Heating Problems

My '92 500SL has problems with the heating/demisting sytem. It sometimes seems to work and sometimes doesn't. This is particularly annoying when trying to demist the windscreen and there is little or no hot air flow. Sometimes the air will start to flow after a few minutes, sometimes it won't.

Occasionally the system will work perfectly! I'm pretty sure it's not just the rotary switch that's at fault. Presumably this switch controls some sort of valve or something.

I recently had the aircon recharged and coincidentally the heating/demisting seemed to be fine for a while afterwards, but I can't see why this may have had an effect.

I've spoken to my tech' who said he won't know what the problem is 'til he strips it down! Perhaps someone here has had this problem and can offer some advice.

Hoping for response!

Kenny
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page