Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2004, 09:53 PM
1988 300sel
Guest
 
Posts: n/a
fuel injector replacement

How may miles are the fuel injectors good for. My 300sel 3.0 has 160,000 and runs fine except it's hard to start when engine is cold or hot.
Reply With Quote
  #2  
Old 02-02-2004, 07:12 AM
Senior Member
 
Join Date: Nov 2002
Posts: 656
honestly, bosch tells you 100k is about it. by the time you pull 'em and clean 'em, that doesn't fix what's worn, only dirty. get injectors, holders and seals and you'd be suprised at the difference. good luck, chuck.
Reply With Quote
  #3  
Old 02-02-2004, 08:00 AM
Registered User
 
Join Date: Mar 2003
Location: Indiana "the region"
Posts: 27
New injectors

When installing new injectors do they need any testing or cleaning? Do I just install and hope they work?
Reply With Quote
  #4  
Old 02-02-2004, 08:54 AM
Registered User
 
Join Date: May 2003
Location: DC Metro Area
Posts: 365
No cleaning / testing needed.

I replaced the injectors on my BMW 735i at about 165k miles, and the process was quite simple. No testing / cleaning was needed. The injectors that I pulled out looked dirty, and I did notice some very small performance improvement. Don't expect it to feel like a new engine, however.

troy
1995 E420 75k
Reply With Quote
  #5  
Old 02-02-2004, 10:42 AM
Senior Member
 
Join Date: Nov 2002
Posts: 656
the injectors in the 735 are opened electrically, not just mechanically. the kjet injectors have a spring that gets weak and a valve face and seat like an engine valve. you do a valve job you repair/replace those surfaces. with the injector, you replace because there is no disassembly. the electronic injectors CAN be disassembled and rebuilt, if neccessary.

the new injectors SHOULD be cleaned and tested for defects. it does happen. had a 560sl that i put injectors into and 1 of them created a miss. shoulda tested them first. good luck, chuck.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page