Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2004, 09:52 PM
Registered User
 
Join Date: Nov 2003
Posts: 9
190e Power Failure? Stall

This is probably about the third time this has happened to me.... I have been through numerous batteries and now I am on an Optima Yellow Top. I have a very powerful car stereo system, 1600watt rms with the stock alternator. One time all of the lights in my console came on and the car stalled, another time the rev meter started spinning, and this time all of the lights in my car dimmed [console,hud,headlights,headunit]. I turned off the radio and all returned to normal. I was told that my stock alternator [190e 2.3 1991] is 70amp. Either it is shot, or not strong enough for my car ? I was told i can do a 95 s420 alternator thats 150amp, if i recall. Any recommendations you may have would be greatly appreciated because I have been stranded one too many times.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page