Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-25-2000, 09:31 PM
Marc P
Posts: n/a
The brakes on my 87 560 SEL pulse. My mechanic has changed the rotors 3 times in the past 6 months. Each time the pulsing disappears for ~ 1000 miles and then comes back an continues to get worse. We checked the torque on the wheels and it was fine. What else could cause the rotors to continually deform?
Reply With Quote
Old 07-25-2000, 09:37 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Heat distortion can cause this. Also, misalignment of caliper brackets and pad retainer pins. Do your pads wear out at the same rate the rotors do?

Jeff Lawrence
1987 300e
1989 300e
2000 Dodge Grand Caravan SE
Reply With Quote
Old 07-25-2000, 09:38 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
What brand of pads & rotors?? Do you do all in-city driving?? Low buck pads can cause excessive heat build-up & cause premature warpage. Do the wheels have Kleen-wheels??
Reply With Quote
Old 07-27-2000, 03:10 PM
Marc P
Posts: n/a
Brake pads are new and are not wearing out. I do not have Kleen Wheels either

Reply With Quote
Old 07-27-2000, 03:37 PM
Registered User
Join Date: Feb 2000
Location: Santa Clarita, CA, USA
Posts: 133
I have experienced this twice with my '82 240D and '84 300SD. I replaced the worn rotors in front with "cheaper" ones...ATE and I thought all was well. A few thousand miles later, I get pedal vibration when braking. I took them to be resurfaced...but the within a month the problem came back. I decided to replace them with BALO rotors. They have their own steel mill and control the quality of the steel as they see fit. I'm really impressed by them. They have been on for several years now and no problems. Same story with the rear rotors...put ATEs and got warpage...put BALOs and problem cured.

On a side note, it could be that you are getting uneven braking causing one rotor to get overworked and overheated causing it to warp. If your mechanic did everything properly and all the "mechanics" of the brakes are working as they should, it may be that the rotors put on there are just of poor quality.

Reply With Quote
Old 07-27-2000, 03:54 PM
yal's Avatar
yal yal is offline
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,704
Check for vent obstructions in the front lower bumper. What kind of wheels do you have?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
560 SEL - headlights McLaren Tech Help 2 03-30-2005 03:07 PM
WTB: 560 SEL parts The_Professor Mercedes Used Parts For Sale & Wanted 0 12-21-2004 03:44 PM
1983 300SD or 1987 560 SEL BenzFreak Diesel Discussion 2 05-19-2003 01:05 AM
1983 300SD or 1987 560 SEL BenzFreak Wheels & Tires 0 05-18-2003 09:07 PM

All times are GMT -4. The time now is 01:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page