Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-19-2004, 11:19 PM
cam69ss's Avatar
Turbo Member
 
Join Date: Sep 2002
Location: Worcester MA
Posts: 291
126 Auto climate control Again! Elec. Tech advice needed

Hello,
I have read in this forum where intermittent climate control problems can be caused by faulty solder joints in the climate control box.

I have a 1990 300SE and it has many climate control problems that appear briefly then go away. Well now I have a bigger problem. The fan does not seem to work. It is hot but the blower does not come on at any speed or setting. This has happened in the past but it would always start to work soon after.



The control box I have is P/N 126 830 10 58
There is only 1 PC board in it, not 3 like some others have mentioned. What solder joints and or components should I check out?

Maybe I have another problem?

Any help would be appreciated.

Thanks
Dan

__________________
1969 RS/SS Camaro Conv. L-89 Alum. Head 396 375HP 4-spd

1987 GNX #419, 2002 RX300

FS: 1934 Ford Street Rod, Blown 383 $48,500 Firm

http://banners.wunderground.com/bann.../worcester.gif
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page