Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-25-2004, 10:49 AM
Lebenz's Avatar
backwoods member
 
Join Date: Feb 2001
Location: In the fog
Posts: 2,862
Thumbs up Something went right!

I had the front and rear brake pads changed out on my ’00 ML yesterday. Went with PBR Deluxe as I couldn’t find ceramic pads for the ML. The brake pad warning light hadn’t triggered, but the ML has almost 45K miles on it, was still using the original brake pads, and the brake pedal went almost to the floor before the brakes engaged. I don’t know why the engineers at MB designed the brake pedal feel for the ML but the design has been the cause of lots of complaints. The brakes work fine and always have, it just takes a lot of pedal travel to get there.

The folks at Phil Smart Classic Car center installed the new pads and sensors in about half a day. They were even cool with my buying the pads at FastLane and having their techs do an install.

But then, after they’d sent a driver to take me to the shop to pick up my ML I got a surprise: There was no charge for the job! How cool is that!

The reason there was no charge for the job was due to a miss-communication on some previous work they’d done for me, which resulted in a minor over-sight.

Anyway, the fast turn around, plus no labor charge was an extremely nice gesture!

What’s even better is with the new pads, the pedal travel has been reduced by about 75%.

It is cool that some folks and the companies they work for do care about customer satisfaction!

:p

__________________
...Tracy

'00 ML320 "Casper"
'92 400E "Stella"
Reply With Quote
  #2  
Old 02-25-2004, 11:59 AM
gmaltz's Avatar
Registered User
 
Join Date: Aug 2003
Location: Long Island, NY U.S.A.
Posts: 102
Wow! That kind of good will would make me a steady customer and I would certainly spread the word to all my friends. To bad I do all my own work though.
__________________
Gerry

59 Ranchero
83 928 Euro S
84 928 Euro S
87 300D Turbo-Frybrid "WVO, Tastes Great - Less Filling"
90 750 IL
91 560 SEL
Reply With Quote
  #3  
Old 02-25-2004, 03:33 PM
Registered User
 
Join Date: Feb 2002
Location: Seattle
Posts: 596
I go to the same place! I recently had my car in for other reasons, and asked them to look at it my water, which they had changed out a few months earlier. I mentioned that when I'd changed my own thermostat -- my fluid was decidedly green -- not the color I'd expect from MB fluid. They drained it, flushed with plain water and replaced with MB mix. They charged me no labor. The service writers at that location are top notch.
__________________
David
1986 300E Anthracite + ECodes + MB Mileage Award
Reply With Quote
  #4  
Old 02-25-2004, 04:56 PM
Registered User
 
Join Date: Jan 2003
Location: St. Louis area
Posts: 109
I hope you checked your rotor thickness! I've had two ML's and the minimum is reached before that many miles!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page