Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2004, 04:17 PM
Registered User
 
Join Date: Apr 2004
Location: California
Posts: 6
Unhappy Windshield squirters, cruise control, clock, odometer not working

New Member - Help, my car is Sick

Reply With Quote
  #2  
Old 04-06-2004, 04:30 PM
chazola's Avatar
Registered User
 
Join Date: Nov 2003
Location: Dorset, United Kingdom
Posts: 1,239
have you checked your fuses? engine compartment at the back, drivers side. rectangular black box next to brake fluid resevoir.
Or they might all just be broke... nothing you can't live without on that list. except for the windscreen squirters.
__________________
1993 320TE M104
---------------------------------------------------
past:

1983 230E W123 M102
1994 E300D S124 OM606 (x2)
1967 250SE W108 M129
1972 280se 3.5 W108 M116
1980 280SE W116 M110
1980 350SE W116 M116
1992 300E W124 M103
1994 E280 W124 M104
----------------------------------------------
"music and women I cannot but give way to, whatever my business" -Pepys
Reply With Quote
  #3  
Old 04-06-2004, 06:03 PM
Registered User
 
Join Date: Dec 2000
Location: AL
Posts: 1,219
Well, what kind of car is it?

Your profile shows you own a "1986 300Eadab" but that car would have a mechanical odometer.
__________________
2012 E350
2006 Callaway SC560
Reply With Quote
  #4  
Old 04-10-2004, 02:37 AM
Registered User
 
Join Date: Oct 2000
Location: Oakland, CA USA
Posts: 221
Not knowing what model, well...
But a similar thing happened to me last month. No cruise, tach, speedo, odometer, oil pressure, fuel level, engine temp or "economy" guage. The only thing working in the instrument cluster was the clock and the outside temp. display. It was just a fuse, which I changed and everything's been fine since.
Reply With Quote
  #5  
Old 04-10-2004, 02:49 AM
Registered User
 
Join Date: Sep 2002
Location: Ewa Beach, Hawaii
Posts: 333
"1986 300Eadab" - I assume that means it's a 1986 300E

Windshield squirters, cruise control, clock- start with the fuse
Odometer - the gears are probably jammed. Cost anywhere between $0(DIY) - $300 to repair. Mine is broken too, I just live with it.

Good luck.
__________________
JR
1986 Gold 300E 4Dr automatic
Reply With Quote
  #6  
Old 04-10-2004, 08:32 AM
Registered User
 
Join Date: Mar 2004
Location: Charleston, SC
Posts: 179
May not be a blown fuse

Use an eraser to scrub the ends of the fuses so they make good contact. I had several things not working and did this and everything came back to life.

__________________
89 190E
2.6L
Arctic white
Grey leather
Sunroof
Pirelli P400 rubber
Smoked corners
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page