Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-09-2004, 01:20 PM
Registered User
 
Join Date: Mar 2004
Posts: 13
sunroof acting strange

I poked around the archive but didn't see this one...

I have a 98 e320. The back of the sunroof raises like normal. But to get it to close I need to push the switch back like I am opening the roof.

Then when I try to open the roof it goes a few inches then stops. I release the switch and reingage and it moves 4 more inches the stops.

Using the key to close the roof has stopped working as well.

I suspect it my be as simple as lubracation but wanted to chech in with you guys.

Thanks,

Paul
Reply With Quote
  #2  
Old 04-09-2004, 01:23 PM
Registered User
 
Join Date: Aug 2003
Posts: 187
I suspect it's a lubrication issue, which in turn keys in some safety catch issue.

Try cleaning all tracks thoroughly, and then spray with WD-30.

don't use vaseline, etc. Tried that once, and it actually impedes sunroof at cooler temperatures.
Reply With Quote
  #3  
Old 04-09-2004, 06:25 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,749
you need to lubricate it with the right stuff. lithium grease I think is what you should use.

Alon
__________________
'92 300CE - Sold
2004 C240 - 744 - C7 Wheels - Android Radio
2002 C320 - 816 - Sport Wagon
Reply With Quote
  #4  
Old 04-09-2004, 07:50 PM
Registered User
 
Join Date: Dec 2003
Location: Rogersville, Missouri
Posts: 156
Paul,
Sound like the sunroof needs to be synchronized to the sensors. Key on, push tilt switch up and hold for a few seconds. Slight click may be heard. Then function test. This is required after a removal of power such as battery disconnect/replacement.

Good luck
__________________
Paulwho
1987 190E-16v,
1988 260E Gone after 19 years of service,
2006 C280 4MATIC Gone to another
2006 OM647 Dodge (Mercedes) Sprinter
Time to find another car
29 years Mercede-Benz Technician, Retired Master Technician/Master Wrench
Master Guild Technician once/ SLR Technician Nine cars serviced
Reply With Quote
  #5  
Old 04-09-2004, 08:30 PM
Registered User
 
Join Date: Apr 2002
Location: Melbourne, Australia
Posts: 280
Unhappy sunroof woes

I have a 1994 C180 Euro and had the same problem 2 years ago. Its all fixed now. Just imagine my shock when 2 tech shops told me to consider about A$1200 in costs for taking out the whole gizmo to find out if the thing has some parts broken or warped or torn???? Even the local Benz dealer told me that. However, due to my luck, I had to go and see the dealer due to a radio aerial which shot out like a spear gun and they greased the rails and brackets and whatever from the top with some super Benz grease and charged me only A$10 for the grease and some labour content. It was still moving a bit slowly and I went to change to a big high power battery and guess what? It moves like a dream now............................like new! Actually it was jamming the tilt action before this cure and also stopped halfway on opening and closing. Cheers and hope you get yours fixed fast.
Reply With Quote
  #6  
Old 04-10-2004, 01:19 AM
dakota's Avatar
Moof !
 
Join Date: Jul 2000
Location: Seattle WA USA
Posts: 469
Do not use anything but MB slide paste - PN 001 989 14 51. It's sold in a rather large tin (50grams?) at the dealer (which is about 10 lifetime's worth). Some places will sell you just a film can full, which will be plenty. Use sparingly. Don't use anything else.

You also might want to check your roof switch before tearing into the sunroof. It may be corroded or sticking.
__________________
Steve
1992 300CE Sportline Sophie
1990 300E Emma - in the family
1979 240D Josephine - sold, but not forgotten
2004 Pacifica AWD
http://web.mac.com/dakota/Mercedes/Home.html
Reply With Quote
  #7  
Old 04-10-2004, 05:28 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
I am going to agree with Paulwho on this issue. This is common when the battery cable is lifted. Not only does the sunroof need to be synced but the side windows as well. I believe that the owners manual describes this.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #8  
Old 04-12-2004, 09:49 AM
PHAEDRUS242's Avatar
Registered User
 
Join Date: Feb 2004
Location: Shakedown Street
Posts: 423
definately try resynching the roof first and USE THE MB SUNROOF GREASE. the stuff is incredible and i would not in good conscience recommend any other produst for the maintenance of your sunroofs moving parts.
Reply With Quote
  #9  
Old 04-12-2004, 03:50 PM
Registered User
 
Join Date: Mar 2004
Posts: 13
The resync did the trick

The resync did the trick. I thought I knew what I was doing with the resync. Just goes to show that it pays to RTFM. This makes perfect sense as I replaced the battery in the middle of the winter.

I will also invest in the proper grease.

Thanks gang!

Paul
Reply With Quote
  #10  
Old 04-21-2004, 12:17 PM
Registered User
 
Join Date: Sep 2003
Location: South Florida
Posts: 62
Re: The resync did the trick

Quote:
Originally posted by Paul_Dierze
The resync did the trick. I thought I knew what I was doing with the resync. Just goes to show that it pays to RTFM. This makes perfect sense as I replaced the battery in the middle of the winter.

I will also invest in the proper grease.

Thanks gang!

Paul
My 98 E-320 just started acting up like that. However, I couldn't find the resync procedure in the manual. I saw Paul's answer but not sure what he meant by "function test". Anyway, you know which section is it in the owner manual?

Thanks
Jeffrey
Reply With Quote
  #11  
Old 07-26-2004, 01:54 PM
Rafi's Avatar
Registered User
 
Join Date: Jan 2003
Location: Garden State
Posts: 474
I read this thread and it was informative. I have two requests:
1. I need a simple step by step instructions for lubricating the sunroof.
2. I need step by step instructions of how to synchronize the sunroof.

I am new with my 99 E300 DT (W210) the sunroof will tilt up but will not go down, it will go back but not close. I have to try to tilt it up to close and try to open it to tilt it back down and the key remote will not do anything with sunroof. The remote works the windows OK.
__________________
2010 ML350 Bluetec
2012 Mustang Convertible
Reply With Quote
  #12  
Old 07-26-2004, 05:19 PM
Rafi's Avatar
Registered User
 
Join Date: Jan 2003
Location: Garden State
Posts: 474
Thumbs up My sunroof now works

OK some progress. my sunroof now works great even the remote control works the sunroof properly. This happened after reseting the sunroof by pressing the sunroof button in for few seconds with key in position 1. Now I would like to grease the sunroof to prevent future problems. Thsi site is great.
__________________
2010 ML350 Bluetec
2012 Mustang Convertible
Reply With Quote
  #13  
Old 11-12-2004, 02:45 PM
Registered User
 
Join Date: Apr 2002
Location: Hollywood Hills, CA
Posts: 891
my 99 e430 sunroof wants to open but it clicks and sounds like it's jammed...

i have to help it close the 1/2 inch that it opened...however the tilt up works fine...
help...
is this a grease issue?

or a synch issue...
thanks

__________________
~there is no spoon~

1984 300CD Turbo Diesel (soon to be "powered by VEGGIE") - dolphin silver

1999 e430 Sport blk/blk, my sexy ***** ;-)

(my other girls)
1992 300CE 24V 3.0L (w124) (R.I.P. "she was killed 7/12/03 by some ricer kids speeding in a honda accord")
1990 Acura Integra RS (w/94' engine)
1966 Cadillac Sedan de Ville (Hardtop)
Reply With Quote
  #14  
Old 11-12-2004, 08:07 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Quote:
Originally Posted by mushedroom
i have to help it close the 1/2 inch that it opened...however the tilt up works fine...
help...
is this a grease issue?

or a synch issue...
thanks

It seems like its neither. I suspect its a sunroof cable issue. Check if the cable is trying to come out of the side rail when you try to open the sunroof.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page