Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2004, 02:55 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
AC Electrical Problem

My AC won't work because the compressor won't come on because, apparently, my compressor relay is not getting a TD (rpm) signal. I'm told this is sort of a safetly feature - the compressor relay compares the engine rpm to the compressor rpm and unless they are the same the compressor won't come on. So my compressor won't come on because it's not getting the engine rpm signal. I realize this is an obscure question but does anyone know where that engine rpm signal comes from, and what might be causing the failure. The wiring harness was recently replaced but I know the AC worked for a while after that.

Reply With Quote
  #2  
Old 04-12-2004, 03:05 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Year and model please......and engine if known...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #3  
Old 04-12-2004, 03:20 PM
LarryBible
Guest
 
Posts: n/a
Yes, we find such information to be quite helpful.

Have a great day,
Reply With Quote
  #4  
Old 04-12-2004, 04:22 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
Boy you guys are fast - I had already realized I forgot the model info, logged back on to edit it and found two posts already. The car is a 1994 E320 coupe, 104 motor, the tach is working fine. Thanks.

Last edited by deanyel; 04-13-2004 at 01:15 AM.
Reply With Quote
  #5  
Old 04-13-2004, 05:43 AM
wbain5280's Avatar
Registered User
 
Join Date: May 2001
Location: Northern Va.
Posts: 3,386
I hope you get it fixed soon, Phoenix is about to become an oven. The car is white, isn't it?
__________________
Regards

Warren

Currently 1965 220Sb, 2002 FORD Crown Vic Police Interceptor

Had 1965 220SEb, 1967 230S, 280SE 4.5, 300SE (W126), 420SEL

ENTER > = (HP RPN)

Not part of the in-crowd since 1952.
Reply With Quote
  #6  
Old 04-14-2004, 12:54 AM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
No, no - the car is black. But when Phoenix turns to an oven, which is a little more than half the year - I leave. But I thought I had it sold to a year-round resident - but the deal fell through - so it's become a low priority project.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page