Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-28-2000, 07:23 PM
Posts: n/a
yes i had the same problem on my euro 85 500selwith 223k. i did everything i could to find out what was wrong and i have the same problems it is the head gasket on mine it has just started to go bad.

[This message has been edited by Benzman500 (edited 08-28-2000).]
Reply With Quote
Old 08-28-2000, 08:49 PM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Easy check for a "slight" head gasket leak at the water jacket - any up-to-date shop should have a sniffer that detects hydrocarbons in the antifreeze. Any positive reaction and you need a head gasket. I had a slight leak on another car, could not locate it, was losing coolant and had no tell tale sign of H2O vapor in the exhaust. A friend with a shop stuck the sniffer in the upper tank which showed a gasket leak. Test took just a few seconds.

Mike Tangas
73 280 SEL 4.5
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page