Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-30-2000, 03:22 AM
Registered User
Join Date: Jul 2000
Posts: 72
Hello all,
My sister's 1984 300CD's acc started acting strangely:
With temp wheel set at 22C system will come on ok but after a while fan will stop.
As temp is lowered fan will come back on and as new temp is reached it will stop again.
It is almost like when the temp is reached and the fan speed should be reduced it stops running instead. I am suspecting an acc amplifier. Any suggestions?
Will be going by Fletcher Jones tomorrow morning and would like to pick an amp up from their wholesale dept. Any early replies appreciated.
Thank you
Joe Brasileiro
1980 450SEL
1987 Jaguar XJ6
1984 300CD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Becker strange behaviour Salty Car Audio and Multimedia 0 05-20-2004 05:32 AM
1984 123 ACC Question 250 LWB Tech Help 1 03-14-2004 11:48 AM
81 Mercedes 123 PARTS FOR SALE on EBAY cpapp Mercedes Used Parts For Sale & Wanted 6 01-21-2004 09:55 AM
disassembly of a ACC pushbutton unit - 123/ 1984 surfblau Diesel Discussion 0 06-09-2003 12:30 PM
Strange ACC problem Kyle Blackmore Diesel Discussion 6 06-05-2002 12:43 AM

All times are GMT -4. The time now is 09:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page