Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-23-2004, 02:34 AM
Registered User
 
Join Date: Nov 2002
Location: Berkeley, California
Posts: 4
Auto trans 88 300TE

Well, I posted last night then deleted it after searching the archives and finding a wealth of information from some very smart people. My compliments to the members here. I only drop in very occasionally.

Anyhow: "the story" I bought an 88 300TE with 167k on the broken odo ( no surprise there). As I drove home it shifted all the way to 4th, then: BAM! down into second for the 10 miles home at 45mph. Lot of angry stares from other drivers.

The car had sat for a year and a half, then sat for another 3 weeks as I waited for the seller to get the title from the lien holder. I went out this morning to go disconnect the kick down switch to see if that was the problem. Pulled back the carpet and it was gone!. Well, that eliminated that. As I drove today the trans shifted a little rough, but through all the gears. I presumed the governor was OK. Called Peter Schmid in Burlingame, CA. He said: "dirt in the valve body from reverse, get a rebuilt unit" They are the place to get a MBZ trans from in the SF area. I decided to try some strong medicine. Trans X. Went to a friends shop and sucked out some fluid and put the stuff in. Immediatley I got torque convertor whine. Not good. but the trans shifted OK not great. I took if for a spin on the freeway and boom, the speedo quit. Hmmmm? What do you think? The gear in the trans?

That torque convertor whine has got to go. I'm going to drain the Trans X out and put in fresh fluid and LubeGard. I have had excellent results with the stuff. I've revived many an Aisin AW70 on Volvos with a power flush and a bottle of their tranny additive. Here's a link.

http://www.lubegard.com/automotive/index.html

My questions; should I put in a pressure regulator spring from Sonnax or the dealer while I have the pan off to replace the filter? What caused the speedo to fail? Anyone else notice a whine while using Trans X?

thanks

240D with a gas 200 motor
Just sold the 6.3
56 190 hearse is long gone
I've lost track of how many pontons
and many more

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page