Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-28-2004, 08:28 AM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
symptom of bad AMM?

I have performed a search reviewing the past posts on AMM sensors, but wanted to know if my symptoms are consistent with a faulty AMM.

With car in neutral, when I rev to 4K rpm, I get a distinct hiccup.

When gas pedal is floored the kick down effect of the transmission seems not to happen. Or it very delayed, seems to be a distinct delay between engine revs and transmission up**** - almost like a slipping torque converter

Also when floored at high speed above 80mph can feel hesitation.

Are these the symptoms of a bad AMM

TIA
Scott
Baltimore

Reply With Quote
  #2  
Old 04-28-2004, 09:45 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Is the Check Engine Light on?
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #3  
Old 04-28-2004, 10:01 AM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
Check engine light was on last week, found a hole in my intake runner, then replaced the intake runner. To turn of the CEL I disconnected the battery, and the CEL has not come on since

Sunday night and again last night when flooring the gas I discovered the hesitation.

Not sure whether this matters, but the new intake runner I purchased ( from dealer ) was slightly different than the original, I had to plug up a nipple that wasn't present on my original.

At normal operating speeds ( moderate acceleration, cruising below sixty mph ) the car runs fine
Reply With Quote
  #4  
Old 04-28-2004, 04:53 PM
Registered User
 
Join Date: Sep 1999
Location: Toronto, Ontario
Posts: 210
What model car do you have Ethan?

My M104 C36 had the same problem as you described it it was the boot ends under the coil pack that was the problem. they are like $10 each.

Good luck.
__________________
1997 Silver AMG C36
OEM Advantegarde Grille
OEM Clear Corners
W210 Blinking mirrors
Eibach/Bilstein Combo
Zender Rear Lip Spoiler
Reply With Quote
  #5  
Old 04-28-2004, 07:57 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
I have a 1998 C230

went to autozone midday and pulled a code P0170

check engine light came on later this afternoon

Rocky, are the boot ends you mention a simple snap connection?
Reply With Quote
  #6  
Old 04-28-2004, 08:46 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
With only that code and no other diagnosis work, you could change the AMM and see if it works. However, if that's not the problem, then you're out the $$ for the AAM. That code [i]usually[/] leads to the AAM, but on my Dad's C230 he coded a misfire and it was a resistor.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #7  
Old 04-28-2004, 09:21 PM
Registered User
 
Join Date: Dec 2003
Posts: 228
Ethen,
Slowdown,

1) C230 has no AAM or AMM but a search on P0170 will probably suggest a MAF mass air flow sensor.

2) In neutral or park ME fuel computer only allows 4000 rpm


3)What was this intake hole?? A vacuum leak would also contribute to p0170
__________________
Paul
Reply With Quote
  #8  
Old 04-28-2004, 10:28 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Quote:
Originally posted by Paulwho
1) C230 has no AAM or AMM but a search on P0170 will probably suggest a MAF mass air flow sensor.
Actually, several techs have taken some time to explain that the car does have the Air Mass Meter, and we have been refering to it as the MAF in error. PM Steve Brotherton and he might explain the subtle differences to you. He is one that was kind enough to point out our error in terminology.

The engine does have the 4K rpm rev limiter when in neutral to keep from overloading an unloaded engine (punny...).

It should be simple to diagnose the AMM with the adaptation values...
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #9  
Old 04-29-2004, 06:43 AM
Registered User
 
Join Date: Sep 1999
Location: Toronto, Ontario
Posts: 210
Quote:
Originally posted by Ethan
I have a 1998 C230

went to autozone midday and pulled a code P0170

check engine light came on later this afternoon

Rocky, are the boot ends you mention a simple snap connection?

P0170 code. I'm 99% sure it's the Air Mass Meter or most people call it the Mass Air Sensor.

I had the same code, changed the MAS/AMM and viola.

Boots i'm talking about sit underneath the coil. Check those and replace them at the same time since they are very cheap and very problematic. Usually change them with every spark plug change.
__________________
1997 Silver AMG C36
OEM Advantegarde Grille
OEM Clear Corners
W210 Blinking mirrors
Eibach/Bilstein Combo
Zender Rear Lip Spoiler
Reply With Quote
  #10  
Old 04-30-2004, 06:26 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
to update the problem I was having - as described in my first post of this topic - a new MAA (MAF) fixed the problem

I ordered the new MAA form Fastlane.

scariest event of the whole problem was the way the bad MAA effected transmission performance

Thank You to all that replied, and for the archived posts
Reply With Quote
  #11  
Old 09-25-2007, 01:16 PM
Registered User
 
Join Date: Aug 2007
Posts: 9
Another old thread, but the reason the problem appeared to effect the tranny, is that the tranny has adapted to the engine running properly, and appears to seem
like it's having a problem when in fact it's simply adapted to the engine
putting out full power.
When you put out less than full power, without resetting the adaptation, it still
is looking for certain parameters to shift, that aren't there when the car is running on 3 cylinders etc.

Anyway, this may be useful info for me, so thank you.
Getting some misfires...but not throwing codes, at least not that i can see with OBD reader.

__________________
2002 C230 Sport Coupe- Orion Blue
ASP Pulley-Supersprint Header-Remus Muffler-
Magnaflow Cat.
TIEN SS Coilovers-
AMG Sways, Wheels, BBK
Tinted windows and tails...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page