Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-14-2000, 09:40 PM
Posts: n/a
I have no power to the A & B terminals in my fuse box. The result is no turn signals, power windows, brake lights, & instrument gauges. I have been tracing wires & replacing relays, but still have no power.
All of the wires from my key switch are hot when the switch is turned on.
Any suggestions?
Reply With Quote
Old 09-14-2000, 09:58 PM
Robert W. Roe's Avatar
Registered User
Join Date: May 1999
Location: Lehigh Valley PA
Posts: 1,321
Did you change the fuses? They can fail and still appear good.
Reply With Quote
Old 09-14-2000, 10:49 PM
Posts: n/a
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Robert W. Roe:
Did you change the fuses? They can fail and still appear good.<HR></BLOCKQUOTE>

There is no voltage on either side of the fuse. The feed wires to the back of the fuse box have no voltage in them.
Reply With Quote
Old 09-15-2000, 07:43 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
According to my wiring diagram fuse a and b are for the power windows. Power to the fuse comes from the window relay code F, term 87 RD/BU wire.

The fuse for the rest of your items is fuse 12 which is powered from the ignition switch.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
auto climate control problem on 91 300D dean enell Diesel Discussion 0 01-10-2005 08:44 PM
Please help with electrical problem 92 300E Uncle Acky Performance Paddock 11 09-26-2003 08:18 AM
w126 fuse #15 problem w/ alarm Snibble Tech Help 8 07-26-2003 10:10 PM
'85 300D Turbo electrical problem.. paxil Tech Help 2 07-10-2002 06:57 AM
Fuse Problem on 500SEL 1985 downsmith Tech Help 2 06-29-2002 05:58 PM

All times are GMT -4. The time now is 01:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page