Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-25-2000, 09:40 AM
rehilg
Guest
 
Posts: n/a
I had the water pump replace on my 94 E320
and now the check engine lite is on, but
no other sign of problems. All sensors appear
to be connected correctly. Can I check the
temp sensors with a VOM? any other ideas
of the cause of the problem?
Reply With Quote
  #2  
Old 02-25-2000, 10:23 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Usually one of the vacuum lines is off or broken...Or it could be unrelated. You will have to take it to the shop for the clearing of the light.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 02-26-2000, 01:45 AM
Registered User
 
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
You may try to take the neg terminal off the battery for 10 minutes to see if you can reset it. This works on older MBs. If your radio is not working after the power interrupt, you need to go to the dealer to activate (for free, I think) the radio.

David
Reply With Quote
  #4  
Old 09-17-2000, 11:42 AM
Registered User
 
Join Date: Sep 2000
Posts: 3
quote:
Originally posted by be459:
You may try to take the neg terminal off the battery for 10 minutes to see if you can reset it. This works on older MBs. If your radio is not working after the power interrupt, you need to go to the dealer to activate (for free, I think) the radio.

David



Yep. Taking off the neg battery lead clears the check engine light after making a repail/replace of the defective part. I replaced defective O2 sensor om '94 E320 and the light remained on. Removing the power for 10 min or so did the trick. Needed to enter anti-theft code in the radio.




------------------
Dave Gillespie
1994 E320 Wagon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light on 94 E420 and a couple of other questions screedchan Tech Help 31 03-24-2006 03:55 PM
Help! Engine Dead???? Breckman99 Diesel Discussion 17 05-10-2005 12:26 AM
1998 E320 Check Engine Electronics Benzstar Tech Help 12 08-09-2004 09:23 PM
check engine light 1994 e320 WRS Tech Help 3 02-07-2002 03:04 PM
Fuel Trim? OBDII cycle and CHECK ENGINE ? ke6dcj Tech Help 1 08-06-2001 09:54 AM



All times are GMT -4. The time now is 01:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page