Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-01-2004, 12:35 PM
Registered User
 
Join Date: Jul 2004
Posts: 2
500SL Engine Problems

Yesterday after I shut my car off and left it for a while it would not re start. I tried 6 times and it just clicked. I then jump started it. I wouldn't start 2 more times, then it fired up and made a terrible clunking noice souded like the timing chain hitting something. My mechanic then removed the passenger side valve cover and the chain appeared to be on track. He then unpluged the cylinoids and I cranked the engine over, he said it didn't look like any valve damage and the chain looked like it was slipping a little every revolution.

What could be the cause of this. I am already having SL with drawls and its only been one day.

Thanks

Jesse Lamison
1992 500sl
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page