Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-05-2000, 07:10 PM
EADG
Guest
 
Posts: n/a
This morning when I started my 91 300E I had no dash or console lights, they were working fine last night though. I changed a couple of the fuses (slot 3 & 5) to no avail. The other items hooked up to these fuses work fine; tach, parking lights, fog lights ect. Where do I go from here? Is it DIY? Burnt out buld or busted dimmer pot? Grr, I've had this car for 7 days and already the muffler fell off, headlight lens cracked and now this. (Muffler replaced @ no charge)
Reply With Quote
  #2  
Old 10-05-2000, 07:38 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
I just went through the same problem. The very first thing you have to do is check the rheostad or dimmer controller which doubles as the miles reset in your instrument cluster. It is the left "handle" in your cluster. Turn it right and left a few times. If after doing that, still does not work, you may have to replace the fuse behind the cluster or the rheostad itself. My car a 86 300E does not the fuse behind the instrument cluster (it looks like a lighbulb, red in color?), MB started installing the fuse in 87's but, I do not know if this applies to your car, since is a 91.
I bet you turned the mileage reset handle by mistake during the day. Try the first suggestion. Good luck!


------------------
J.H.
'86 300E
Reply With Quote
  #3  
Old 10-05-2000, 07:50 PM
EADG
Guest
 
Posts: n/a

Reply With Quote
  #4  
Old 10-05-2000, 08:29 PM
EADG
Guest
 
Posts: n/a
Yep... the dimmer knob was the first thing I tried, twisted and turned every-which way. Since I've only had the car for a week I have no manuals (other than the owners), could somebody tell me how to remove the instrument cluster so I can get to the dimmer pot.
Thanks.
Reply With Quote
  #5  
Old 10-14-2000, 01:31 AM
EADG
Guest
 
Posts: n/a
Her's a follow up to the problem... hopefully somebody will find this of use when looking through the archives.
A mechanic pulled the intrument cluster with a pair of long, straight, thin Allen Keys bent 90 degrees 1/4" from the ends. Inserted them where the dash meets the air vents on either side of the cluster, twisted and pulled. After disconnecting the bulbs, and a few other wires a quik inspection revealed a broken solder joint on, what I believe, was the dimmer pot... a quik and easy repair.
Now I have my dash and console lights working again, making night time driving a little bit more enjoyable.

Cheers for now.
EADG
91 300E

Reply With Quote
  #6  
Old 04-01-2002, 12:40 PM
javid mian
Guest
 
Posts: n/a
CLUSTER LIGHTS.

THANKS FOR THE INFO I WILL TRY THAT NEXT.SO FOR I AM USING THE FLASH LIGHT .
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument lights still dead; rheostat bypassed The Warden Diesel Discussion 13 04-08-2005 12:43 PM
Fog lights and high beams on together? euronatura Tech Help 11 01-15-2004 10:48 PM
300E Euro Lights Impressions anm Tech Help 5 01-29-2002 02:15 PM
Euro Headlights DZLPWR Diesel Discussion 10 10-07-2001 01:03 PM
Quick Cibie question....... DieselHead Diesel Discussion 3 09-21-2001 05:38 PM



All times are GMT -4. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page