Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-13-2000, 08:34 PM
Posts: n/a
Another new problem in my CLK. I hope to avoid going to the dealer again (the less it is there the better)
Once I reach about 90km/h the speedo stops moving up smoothly (it moves in bursts of about 5-8 km/h) even though I continue to accelerate at a constant rate. Below 90 is ok. It only does this as speed increases, not if speed decreases, that is it will decelerate smoothly from any speed.
I have gone as high as 160 km/h to test (haven't been on the hiway, only city) and it exibits this behaviour consistantly above 90km/h.
Any ideas ? Could some piece of dirt of something have fallen in there somewhere ? The dash was recently replaced at the dealer.
Reply With Quote
Old 10-18-2000, 02:12 PM
Registered User
Join Date: Oct 2000
Location: Columbus, Ohio, USA
Posts: 72
Was your stereo on during this event?

I have noticed that bass from my speakers in the front dash causes my speedometer needle to jump 3-4mph. IT only happens for me when I am accelerating at speeds over 45mph (top dead center for my gauge)

I don't think this will help, but, you never know.

Jeff Biesenberger

'84 Euro 300D 261k miles
Reply With Quote
Old 10-19-2000, 12:00 AM
Posts: n/a
Thanks, but nothing to do with the stereo. I have had that situation in other vehicles though.
Reply With Quote
Old 10-19-2000, 07:21 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
It is my impression that all the instument needles in that IC (inst cluster) are stepper motors responding to a calculated value. That would make me think that the problem is more likely to be the motor than the signal (or the processor). Although poor circuitry could cause the processor to have bad output.

Does the speedo act similarly if accelerating with the "Accel" funtion of the cruise control. If the acceleration is smooth on the cruise control I would presume that the speed signal is good; which leaves the IC. Is it out of warrantee??

Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
speedo cable removal at transmission lee polowczuk Tech Help 9 11-24-2004 09:01 AM
How do you remove Speedo Needle? Phalcon51 Tech Help 5 10-05-2003 01:43 PM
sticky speedo needle Hocky Tech Help 1 03-07-2003 08:04 AM
Speedo cable smartin Diesel Discussion 6 02-05-2003 01:55 AM
speedo is flaky mhingram Tech Help 2 01-06-2003 05:54 PM

All times are GMT -4. The time now is 12:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page