Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-25-2004, 01:07 PM
Registered User
 
Join Date: Jul 2004
Posts: 2
Defective lamp indicator is defective

My wife has a 1994 E320. The defective lamp indicator on the dash goes on when the brake pedal is pushed and stays on until the ignition is turned off. The brake light lamps work just fine. So how do I get the warning lamp to work just fine?? Thanks for any help anyone can offer.
Reply With Quote
  #2  
Old 07-25-2004, 01:18 PM
Registered User
 
Join Date: Jul 2003
Location: Norfolk VA
Posts: 142
Is the 3rd (back window) brake light working? This is often overlooked. Also, make sure bulbs are the correct wattage.

Good luck!
Reply With Quote
  #3  
Old 07-25-2004, 04:53 PM
Member
 
Join Date: Jan 2003
Location: Florida
Posts: 1,084
bubs

I would check for corrosion.if it comes on when you put on the brake it is in the brake circuit! The module rarely goes bad.
Reply With Quote
  #4  
Old 07-25-2004, 09:06 PM
Registered User
 
Join Date: Jul 2004
Posts: 2
Thank you JR! It was the back window brake light. Now why didn't I think of that.

cooker
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page