Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2014, 04:56 PM
Registered User
 
Join Date: Sep 2014
Posts: 10
W124 E420 Stumbling under load

I've been trying to figure this issue out. It seems it's worse when it gets warm. If you drive the car like a grandpa, it's fine, but if you try and accelerate with any sort of urgency, it'll sit there and stumble/misfire until it get above approx. 2k rpms then it'll take off fine. I changed fuel pumps and fuel filter. My next step was going to be spark plugs. I inspected them today and they do look like they've been in there a while, but I cleaned them up and put them back in, and no improvement at all. I'm sure it could use new plugs, wires, dist. cap, rotor, etc, but money for this car is tight and I'd like to make sure that's it before spending several hundred dollars on all that.

The only other issue it has when running is if you stab the throttle when in park, RPMS will raise fine, then drop very low and almost stall, then return to normal idle. I'm not sure if these could be related.

I've always worked on my own cars, but this is the oldest car I've owned and it is making me realize how dependent I've been on just plugging in a computer and seeing everything that's happening.
Reply With Quote
  #2  
Old 09-27-2014, 02:17 PM
Registered User
 
Join Date: Feb 2010
Location: Hawaii
Posts: 76
You can build the home brew code reader for cheap. I would pull the caps and look at them. Try lightly cleaning the contact points with an emery board. You can test the fuel pressure regulator by removing the vacuum line at idle. If it's leaking fuel its bad. The right plugs for these cars are cheap. I would pull one and if it looked bad spend 20 and replace them.

One baseline check. Look at the tag for the upper harness. Make sure it's been replaced with a post 1997 build.
Reply With Quote
  #3  
Old 09-27-2014, 03:35 PM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,882
check for vacuum leaks
__________________

1990 190E 2.6L
Reply With Quote
  #4  
Old 09-29-2014, 12:28 AM
Registered User
 
Join Date: Sep 2014
Posts: 10
Thanks guys. I haven't had the chance to check on this since I posted. Is this tag on the harness something that's pretty obvious? I just want to make sure when I go to look, I know what I'm looking for.
Reply With Quote
  #5  
Old 09-29-2014, 01:13 AM
Registered User
 
Join Date: Sep 2014
Posts: 10
Thanks. I hate getting into a car I know nothing about and being a "noob" again.
Reply With Quote
  #6  
Old 09-29-2014, 07:34 PM
Registered User
 
Join Date: Sep 2014
Posts: 10
Wiring harness is dated 2010, so it should be all good. I guess this weekend I start with cleaning out the caps, then go from there.
Reply With Quote
  #7  
Old 10-25-2014, 11:18 AM
gerryvz's Avatar
"Unhinged Troll" - Jim B.
 
Join Date: Dec 2001
Location: The Woodlands, TX
Posts: 1,268
Did you get the problem solved? All good?


Sent from my iPhone using Tapatalk
Reply With Quote
  #8  
Old 10-25-2014, 11:21 AM
Registered User
 
Join Date: Sep 2014
Posts: 10
I did! Did new distributor caps and rotors, and it didn't help, it actually got worse after. So I did plugs and wires and it fixed it. I think it got worse because disturbing the wires to do caps and rotors probably made their already poor continuity worse. Still hunting around for a fix for an RPM drop when revving it though, but think it's just because mine has such a low idle that I should address sometime. When warm, it idles just above 500rpm in neutral, and at or below 500rpm when in drive.
Reply With Quote
  #9  
Old 10-30-2014, 03:51 PM
Registered User
 
Join Date: Oct 2014
Location: Rydaholm, Sweden
Posts: 5
Had a 2000, E240 estate, lovely car...............then on ocassions it just would do quicker than 20 mph, auto box stuck in 1st or 2nd......happened a few times, the computer had gone into Limp Home Mode.................this was quite a few since I sold it.....but that was the problem
Reply With Quote
  #10  
Old 11-02-2014, 08:02 AM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
Quote:
Originally Posted by gerryvz View Post
*********

Any possible issue with your car has been documented & solved there.


Sent from my iPad using Tapatalk HD
Gerry, a link to your site that you are plugging isn't very helpful UNLESS it includes a link to a specific thread that deals with this specific issue.

Folks, you don't need to go to this self confessed troll gerryvz's's site. All he is doing here is trying to cannibalize our site, trying to add members to his site at our site's expense. Literally robbing our site of it's members! He is undermining our community here! Nearly every post he makes here contains a link to his site!

Just do a search here on PeachParts! The search function works much better here!

Regards,
Eric
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.

Last edited by 400Eric; 11-04-2014 at 03:10 AM.
Reply With Quote
  #11  
Old 11-04-2014, 07:02 PM
Registered User
 
Join Date: May 2007
Location: Arizona
Posts: 757
Not to get sidetracked from the OP, but I have been a member of both sites for years. I have found both sites to be very helpful and I try to contribute my experiences to both sites where I can. The 500e board does have some great information for owners who are dealing with the M119 engine or the W124 chassis--you posted a lot of this information yourself.

I'm not seeing how GVZ is trying to cannibalize anything. To my knowledge, he has never asked for--nor accepted--contributions from members to maintain the 500e board. Many of the 500e board members frequent this site too. I don't know what happened between you two guys, but I can't imagine that GVZ deserves the comments above. Sorry to hear about your dog, Eric. I have been there and I know how difficult it is to deal with that. I still miss mine after five years. I do miss seeing your posts over on the 500e board.
__________________
1993 400E, 256,000 miles (totaled)
1994 E420, 200,000+ miles
1995 E420, 201,000 miles
Reply With Quote
  #12  
Old 11-04-2014, 08:49 PM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
Quote:
Originally Posted by emerydc8 View Post
Not to get sidetracked from the OP, but I have been a member of both sites for years. I have found both sites to be very helpful and I try to contribute my experiences to both sites where I can. The 500e board does have some great information for owners who are dealing with the M119 engine or the W124 chassis--you posted a lot of this information yourself.
Yes, I did post A LOT of that info there myself, but at post #228 of this thread: Bolt on performance exhaust for the 500e (testing waters) - Page 4 Gerry posted this:
Quote:
Originally Posted by gerryvz View Post
Let him go. He will be missed, if for amusement purposes. His posts have been on my ignore list for the past few weeks, and I've had to spend an inordinate amount of time deleting & moderating his stuff.
Completely discounting, dismissing, and undermining everything I've ever done there. And he failed to mention that for EVERY SINGLE ONE OF MY POSTS HE HAS HAD TO DELETE AND/OR MODERATE, HE HAD TO DELETE AND/OR MODERATE ONE OF CLARK'S POSTS AS WELL! Not to mention that he has had to delete and or moderate many of Clark's other posts too! Clark is a complete and utter tool but Gerry keeps him around so that he can have the bragging rights of having another tech on his site. Seriously, Klink is all anyone needs. Really! Clark is a blight on that site. He seriously degrades it.

Quote:
Originally Posted by emerydc8 View Post
I'm not seeing how GVZ is trying to cannibalize anything.
Here are some examples of what Gerry's been doing over here:
http://www.peachparts.com/shopforum/performance-paddock/359051-94-e500-engine-simply-shut-down-while-running-wont-start.html#post3402341
http://www.peachparts.com/shopforum/tech-help/361324-trying-build-blink-code-reader.html#post3401216
http://www.peachparts.com/shopforum/featured-cars/360879-mercedes-benz-g-wagen-turns-35-years-old.html#post3396611
http://www.peachparts.com/shopforum/tech-help/360252-w124-e420-stumbling-under-load.html#post3390754
http://www.peachparts.com/shopforum/diesel-discussion/347300-dang-you-%FCro-other-tales-woe-17.html#post3399446
(This last post doesn't have a link to his site per se but he still manages to plug his site just the same.)

And there are many more examples. So many in fact, that, as we speak, an admin is on this.

Quote:
Originally Posted by emerydc8 View Post
I don't know what happened between you two guys, but I can't imagine that GVZ deserves the comments above.
Well, this is a good example of why Gerry DOES deserve the above comments:
Quote:
Originally Posted by gerryvz View Post
Your ranting about your dead mutt on my site caused dozens of people to roll their eyes in off-topic disgust.

Feel free to tattle to the admins here about my constant referrals of M119 124 questions to *********.
That post is here: http://www.peachparts.com/shopforum/performance-paddock/359051-94-e500-engine-simply-shut-down-while-running-wont-start.html#post3403046

Quote:
Originally Posted by emerydc8 View Post
Sorry to hear about your dog, Eric. I have been there and I know how difficult it is to deal with that. I still miss mine after five years. I do miss seeing your posts over on the 500e board.
Thank you for that.

Regards,
Eric
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.

Last edited by 400Eric; 11-04-2014 at 09:33 PM.
Reply With Quote
  #13  
Old 11-04-2014, 11:20 PM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
Quote:
Originally Posted by emerydc8 View Post
To my knowledge, he has never asked for--nor accepted--contributions from members to maintain the 500e board.
I forgot to address this. It's not about money for Gerry because he has PLENTY of that. This is simply an ego trip deal for him. He simply wants to "one up" these other sites and have a place online for Benz folks where he is the "God". And Heaven help anybody who disagrees with him.

Regards,
Eric
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.
Reply With Quote
  #14  
Old 11-05-2014, 12:55 AM
Registered User
 
Join Date: May 2007
Location: Arizona
Posts: 757
My apologies to the OP. We are really off subject and maybe the moderators can move this to a separate area.

First, I am really sorry to hear about your dog and I certainly didn't roll my eyes at your dog post. I don't think that many guys were bothered by your posting it. Actually, as a dog person, I feel that it is much more important than anything that goes on in an Internet chat room.

As for Gerry, I agree that his comment about your dog post was inappropriate. I don't know what led him to say that but that's definitely not how I feel.

You know, I have found that most guys on Internet sites like to be right, especially when they usually are right. It's all about pride. It's not just the car sights. I see it on aviation/pilot sites to the point that I entirely stopped posting on the pilot sites because of the overinflated egos. You think the Mercedes site is bad?
__________________
1993 400E, 256,000 miles (totaled)
1994 E420, 200,000+ miles
1995 E420, 201,000 miles
Reply With Quote
  #15  
Old 11-05-2014, 03:16 AM
Knappy Drag Racer
 
Join Date: Jun 2008
Posts: 1,725
Quote:
Originally Posted by emerydc8 View Post
My apologies to the OP. We are really off subject and maybe the moderators can move this to a separate area.

First, I am really sorry to hear about your dog and I certainly didn't roll my eyes at your dog post. I don't think that many guys were bothered by your posting it. Actually, as a dog person, I feel that it is much more important than anything that goes on in an Internet chat room.

As for Gerry, I agree that his comment about your dog post was inappropriate. I don't know what led him to say that but that's definitely not how I feel.

You know, I have found that most guys on Internet sites like to be right, especially when they usually are right. It's all about pride. It's not just the car sights. I see it on aviation/pilot sites to the point that I entirely stopped posting on the pilot sites because of the overinflated egos. You think the Mercedes site is bad?
Thank you emerydc8. You are a stellar individual!

Regards,
Eric
__________________
89 300E "Benzer1" 15.924 Uncorrected
93 400E "Benzer3" 14.200 U.C.
95 E420 "Benzer4"
92 300E "Benzer5" 16.299 U.C. Future turbo CNG
87 300D "Benzer7"
87 300D "Benzer8"
87 300D "Benzer9"
87 300D/70 AMC Javelin "Sidewinder-Benzer"
87 300TD "Benzer11"
06 E320 CDI "Benzer12"
05 E320 CDI "Benzer12A"
71 AMC Javelin AMX 401 "Sidewinder"
74 AMC Hornet 401 "C.K.10" 13.63 U.C.
74 Bricklin SV1 "Presto" AMC 360 pwrd.

Last edited by 400Eric; 11-05-2014 at 07:16 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page