Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-20-2004, 12:49 PM
Registered User
 
Join Date: Aug 2004
Posts: 124
Thumbs up Easy fix on climate control on an '85 300D

Thought I would put this in it's own post in addition to the other long post it's written about. Been trying to get climate controls working, had access to a used control unit and blower fan, put both of those in with no change, no voltage at the fuses, was going to post with a question about where to start looking next, and then while turnig the car off it comes on full blast for a second! After some experimentation it turns out the ket will stay turned a tiny bit to the right of the normal run position after starting which breaks the connection to the climate controls. Maybe it's designed to temporarily cut off the current to the AC during starting and the lock cylinder spring has aged enough to not fully return the the run position fron the start position. So, if your unit seems totally dead it could be a key problem, not a problem in the unit itself...

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page